App slow processing times
Incident Report for ShopWired
Resolved
The Google Shopping app has completed its processing and is functioning normally.

This incident is now resolved.
Posted Dec 10, 2024 - 13:58 GMT
Update
The Google Shopping app is currently finishing off its processing of a backlog of product listing and stock sync updates to Google Merchant Center. We expect that this process will be completed by 1.00pm today (10/12/2024) after which time normal syncing times will resume.

We will post a further update once the process has completed.

The Veeqo app continues to function normally. No other apps were affected by this incident.
Posted Dec 10, 2024 - 09:27 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 10, 2024 - 02:15 GMT
Identified
The Veeqo app is now functioning as normal and any delayed stock and order messages have now been processed.

A fix for the Google Shopping app has also been implemented and we are monitoring results. Processing is still currently delayed.
Posted Dec 09, 2024 - 16:52 GMT
Update
We have identified the cause of the issue for Veeqo and have implemented a fix. Currently old stock sync and order messages are being synced and we expect normally syncing times from 2.30pm today (09/12/2024).

Work continues on Google Shopping.
Posted Dec 09, 2024 - 11:28 GMT
Investigating
We are currently investigating slow processing times on the Veeqo and Google Shopping apps. The issue is affecting:

- The processing of stock sync updates with Veeqo
- The processing of order exports to Veeqo
- The processing of all listing updates to Google Shopping (including the creation of new listings)

All other apps are working normally.
Posted Dec 09, 2024 - 09:04 GMT
This incident affected: ShopWired Apps (Heroku).