Security update
Incident Report for ShopWired
Resolved
The updates have been completed.
Posted Mar 29, 2022 - 23:46 BST
Investigating
We are currently applying a security update to ShopWired.
Posted Mar 29, 2022 - 23:44 BST
This incident affected: Websites and ShopWired Admin System.